Supported Platforms

Avantra Agent

Agent Operating Systems

This is a list of verified architectures upon which the Avantra Agent has been tested and will function correctly. The Avantra Agent may work on other Linux distributions correctly as long as you have the GNU C Library (glibc) version 2.7 or higher installed along with the required JRE version 8

  • Red Hat Enterprise Linux (RHEL)

    • 7

    • 8

    • 9

  • SUSE Linux Enterprise Server (SLES)

    • 9

    • 10

    • 11

    • 12

    • 15

  • Ubuntu

    • 18.04 LTS

    • 20.04 LTS

    • 22.04 LTS

  • IBM AIX

    • 6.1 or higher

  • Microsoft Windows Server

    • Windows Server 2008 R2

    • Windows Server 2012

    • Windows Server 2012 R2

    • Windows Server 2016

    • Windows Server 2019

    • Windows Server 2022

Windows Server 2008 R2 is only supported by Avantra Agent from the 20.5 code line as this is the last version of the Avantra Agent that supports 32-bit architecture. This Avantra code line is only receiving security updates and will not support newer features, e.g. automation.
  • Oracle Solaris (SPARC and x86_64 architecture)

    • 10

    • 11

A Java 8 Runtime Environment is required for the Avantra Agent.

On Linux, you need to have the GNU C Library (glibc) version 2.7 or higher installed.

SAP Basis

The Avantra Agent monitors the following SAP Basis Releases:

  • Releases 4.6C, 4.6D

  • Release 6.40

  • Releases 7.0x, 7.1x, 7.2x, 7.3x, 7.4x, 7.5x, 7.7.x

Unicode Kernels are supported as well.

SAP BusinessObjects

The Avantra Agent monitors SAP BusinessObjects 4.2 and higher versions.

Databases (stand-alone and SAP Database instances)

  • IBM DB2 Universal Database 8.2.2 and higher (on all available operating systems mentioned above)

  • Oracle8i, Oracle9i, Oracle10g, Oracle11g, Oracle12c, Oracle18c, Oracle19c (on all available operating systems mentioned above)

  • MaxDB 7.5 and higher (on all available operating systems mentioned above)

  • Microsoft SQL Server 2000, Microsoft SQL Server 2005, Microsoft SQL Server 2008, Microsoft SQL Server 2008 R2, Microsoft SQL Server 2012, Microsoft SQL Server 2014, Microsoft SQL Server 2016, Microsoft SQL Server 2017, Microsoft SQL Server 2019 (on Microsoft Windows operating systems)

  • SAP HANA 1.0, 2.0

  • SAP SQL Anywhere 16 and higher (on all available operating systems mentioned above)

  • SAP Sybase ASE versions 15.7 and higher (on all available operating systems mentioned above)

  • SAP IQ of version 16.0 and higher

  • PostgreSQL of version 10.x and higher (in all {_avantra} editions, starting from release 23.0 and higher)

Avantra Server Components

The Avantra Server, running Avantra Master, Avantra Database, and other applications, is supported on the following platforms:

Databases

  • PostgreSQL is the recommended database for Avantra installations on Unix systems, especially for larger management scenarios. Avantra supports the following PostgreSQL versions:

    • 13

    • 12

    • 11

    • 10

Avantra previously supported PostgreSQL 9.6 however this is now no longer supported by PostgreSQL and is no longer recommended for use with Avantra.
  • Microsoft SQL Server 2017, and Microsoft SQL Server 2019 (US English Language Version) on Microsoft Windows operating systems:

    • If customers have extended support for Microsoft SQL Server 2012, Microsoft SQL Server 2014 or Microsoft SQL Server 2016, these databases should also function correctly with Avantra; however we recommend using a later version of this database with current and ongoing support.

    • For large environments (> 1000 servers) we recommend considering the use of PostgreSQL as the database for your Avantra server.

    • For small environments, i.e. up to 20 managed SAP systems (including 25 application instances and 25 servers), Microsoft SQL Server Express Edition will suffice. However, there is a size limit of 10 GB for this database which will limit data retention capabilities.

Avantra Server Operating Systems

This is a list of verified architectures upon which the Avantra Server has been tested and will function correctly. The server may work on other Linux distributions correctly as long as you have the GNU C Library (glibc) version 2.7 or higher installed along with the required JRE version 8.

  • Red Hat Enterprise Linux (RHEL)

    • 8

    • 9

  • SUSE Linux Enterprise Server (SLES)

    • 12

    • 15

  • Ubuntu

    • 20.04 LTS

    • 22.04 LTS

  • Microsoft Windows Server

    • Windows Server 2019

    • Windows Server 2022

For the Avantra Server, only operating systems that are in general (not extended) maintenance by the OS vendor are supported.

Java Runtime

At this time, we recommend using Java runtime version 8 only. We recommend the use of the Temurin JRE as provided by Adoptium from the Eclipse foundation (formerly known as Adopt OpenJDK). As per the support matrix from Adoptium, Temurin 8 currently has an announced support timeframe that is longer than all other Temurin versions (at least May 2026 at time of publication).

Hardware Recommendations

As minimum hardware requirements we recommend:

  • A reasonably new dual-core CPU, 2GHz or more

  • 8GB physical RAM

  • At least 50GB disk space for the application and its data.

For more than 300 managed SAP Systems:

  • A reasonably new quad-core CPU, 3GHz or more

  • 16GB physical RAM

  • At least 100GB disk space for the application and its data.